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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial data 
files to be used to create maps inside a vector graphics program. MAPublisher allows all your cartographic tasks to 
be performed where they should be done; in a powerful graphics environment.

MAPublisher 8 improves on the already powerful tools of previous versions by adding additional file support, 
additional tools, and improvements to existing tools.

This tutorial guide assumes that the user is familiar with Adobe Illustrator CS3 or CS4, and has at least a basic 
understanding of geographic information systems (GIS) terminology and concepts. The tutorials in this guide 
should be used in conjunction with the MAPublisher 8 User Guide.

By following these tutorials, you will learn how to create maps using the MAPublisher features and tools in Adobe 
Illustrator. This guide covers the steps necessary to build a map and perform fundamental cartographic and GIS 
tasks. Together, MAPublisher and Adobe Illustrator will give you a totally integrated cartographic design software 
system with graphics tools and geographic functions present in the same work environment.

TUTORIAL DATA

The tutorials in this guide use GIS data supplied on the MAPublisher 8 CD or in the electronic download. 
Alternatively, if you have installed the software, you can find the Tutorial data in the following location on your 
hard drive:

Windows XP
C:\Documents and Settings\All Users\Shared Documents\Avenza\MAPublisher 8\Tutorial Guide & Data\Tutorial Data

Windows Vista and Windows 7
C:\Users\Public\Documents\Avenza\MAPublisher 8\Tutorial Guide & Data\Tutorial Data

Note:	 This data may be accessed through shortcuts available through the Windows Start menu.

Mac OS X
/Applications/Avenza/MAPublisher 8/MAPublisher Tutorials/Tutorial Guide/Tutorial Data

Helpful styles and symbols can be found in: 

Windows XP
C:\Documents and Settings\All Users\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols

Windows Vista and Windows 7
C:\Users\Public\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols

Mac OS X
/Applications/Avenza/MAPublisher 8/Helpful Styles & Symbols 
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1  Importing Map Data
See User Guide, Chapter 3. 

1.1	 Import a single map file

1.	 In Adobe Illustrator, create a new document in landscape orientation.
2.	 In the Adobe Illustrator menu, click File > Import Map Data > Simple to open the MAPublisher Simple Import 

dialog box or click the Simple Import button on the MAPublisher toolbar.
3.	 Select MapInfo MIF/MID [*.mif] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select world.mif, and click Open.

The Source Coordinate System is automatically read as WGS 84 because MAPublisher has the ability to interpret 
this information if it is contained in the data.

5.	 Make sure that the dialog box matches the one above and click OK.

The data is imported and automatically fitted to the width of the artboard. Notice that in the Adobe Illustrator 
Layers panel there is a new layer called world_area. In the MAP Views panel there is a new MAP View holding the 
imported file called world. See chapter 4 for more information on MAP Views in the MAPublisher User Guide.

6.	 Close the document without saving.
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1.2	 Import multiple map files at once

Simple Import also allows multiple map files to be imported at once. When importing multiple files, all files must be 
of the same format, be in the same coordinate system, and be located in the same directory.

1.	 In Adobe Illustrator, create a new document in portrait orientation.
2.	 In the Adobe Illustrator menu, click File > Import Map Data > Simple to open the MAPublisher Simple Import 

dialog box or click the Simple Import button on the MAPublisher toolbar.
3.	 Select MapInfo MIF/MID [*.mif] from the Format drop-down list (it should already be selected by default).
4.	 Click Browse, navigate to the Tutorial Data folder, select both fsatoronto.mif and torontostreets.mif (hold the 

Command key (Mac) or the Ctrl key (Windows) to select multiple files), and click Open.

Although two files are selected for import, the Dataset box only lists the last file (alphabetical order).

5.	 Make sure that the dialog box matches the one above and click OK.

In the Adobe Illustrator Layers panel, there are new layers called fsatoronto_area and torontostreets_line. In the 
MAP Views panel there is a new MAP View called fsatoronto holding the two imported files.

6.	 Close the document without saving.
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1.3	 Import map files to match an existing map layer

1.	 In Adobe Illustrator, create a new document in landscape orientation.
2.	 In the Adobe Illustrator menu, click File > Import Map Data > Simple to open the MAPublisher Simple Import 

dialog box or click the Simple Import button on the MAPublisher toolbar.
3.	 Select MapInfo MIF/MID [*.mif] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select worldwest.mif, and click Open.

The selected file appears in the Dataset file list in the MAPublisher Simple Import dialog box. Notice that the 
Source Coordinate System is automatically read as Robinson.

5.	 Click OK to complete the import.

In the Adobe Illustrator Layers panel there is a new layer called worldwest_area. Also in the MAP Views panel 
there is a new MAP View called worldwest that is set in the Robinson coordinate system.

6.	 Repeat steps 2 to 4 above to import worldeast.shp, ensure the import Format drop-down list is ESRI Shapefile [*.shp].

In the Simple Import dialog box, the Source Coordinate System of worldeast.shp is automatically read as Robinson.

7.	 Click OK to continue the import process.
8.	 In the Matching MAP View Found dialog box, accept the default Add to: worldwest option in the Destination MAP 

View frame. Then check Resize MAP View to fit.
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The worldeast layer is imported to match the previous import, worldwest. Notice that the worldwest_area layer 
is scaled so that it both layers fit inside the page extents. In the Adobe Illustrator Layers panel there is now an 
additional layer called worldeast_area. In the MAP Views panel, the MAP View worldwest now contains both layers.

9.	 Close the document without saving.

1.4	 Import map files with point per path limitations 

1.	 Create a new Adobe Illustrator document in portrait orientation.
2.	 Click the Simple Import button on the MAPublisher toolbar.
3.	 Select MapInfo MIF/MID [*.mif] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select greenland.mif, click Open and then click OK

The vertex count exceeds the allowable 32,000 points per path in Adobe Illustrator. Greenland looks distorted 
because there is no coordinate system defined.

5.	 Click OK to close the warning dialog box.

MAPublisher calculated the amount of vertices in the file and removed just enough points in order to maintain 
the highest level of detail possible.

6.	 Close the document without saving.
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1.5	 Import GIS file types that require optional settings

There are a number of other file formats in the Tutorial Data folder to experiment with. MAPublisher can handle 
supported file formats in various ways. Some types of data import differently and require additional user input. 
There is an overview of the file formats supported by MAPublisher in the User Guide.

1.	 Create a new Adobe Illustrator document in portrait orientation.
2.	 Click the Simple Import button on the MAPublisher toolbar.
3.	 Select ESRI Interchange File [*.e00] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select capeverde.e00, and click Open.
5.	 In the Simple Import dialog box, click the Settings button.
6.	 Make sure Ignore TIC layer is unchecked, and click OK.
7.	 Click OK to complete the import.

Note:	 As e00 files are generally an archive of several files, MAPublisher will reproduce an e00 import as distinct 
Adobe Illustrator layers. Notice that MAPublisher generates point, area, line and text layers. An extra layer 
appended with _tic_point is created to hold tic points, as was specified in the Settings dialog box.

8.	 Close the document without saving.

1.6	 Import points

MAPublisher can import delimited ASCII text files as point data provided they contain coordinate values. Supported 
delimiters include: comma, return, end of line and tab in multiple formats. Below is an example of ASCII that is 
supported for import:

“AZ,Antonio Tank,reservoir,Santa Cruz,4,23,312004N,1103943W,31.33444,-110.66194,,,,,,,Duquesne"
“AZ,Agua Prieta Substation,locale,Cochise,4,3,312006N,1093335W,31.335,-109.55972,,,,,,,Douglas"
“AZ,Adobe Spring,spring,Santa Cruz,4,23,312037N,1110234W,31.34361,-111.04278,,,,,,,Pajarito Peak"

1.	 Create a new Adobe Illustrator document in portrait orientation.
2.	 Click the Simple Import button on the MAPublisher toolbar.
3.	 Select Delimited XY Text Data [*.csv, *.tsv, *.txt]  from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, and select azdeci.txt.

The Settings dialog box opens automatically. Specify the appropriate coordinate format of their data in the 
Format drop-down list before selecting the columns of the import file to be used.
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5.	 Use Decimals Degrees (D+[.d*]) as the Coordinate Format
6.	 Use Column #10: -110.66194 for the Longitude coordinates and Column #9: 31.33444 for the Latitude coordinates.
7.	 Leave Use first line as a header unchecked. The first line of this file does not contain column headings.

8.	 Make sure that the dialog box matches the one above and click OK.
9.	 Since the file contains coordinates in decimal degrees, click Specify, select the WGS 84 coordinate system from 

Geodetic > World, and click OK.

10.	 In the Simple Import dialog box, click OK to start the file import process.
The points are placed on the page as specified. All other columns that were in the file are imported as attribute 
data for the placed points.

11.	 Save this document as MyPoints.ai in the Tutorial Data folder. It will be used again in Tutorial 8.3.
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1.7	 Import multiple file types

1.	 Create a new Adobe Illustrator document in landscape orientation.
2.	 In the Adobe Illustrator menu, click File > Import Map Data > Advanced to open the MAPublisher Advanced 

Import dialog box or click the Advanced Import button on the MAPublisher toolbar.
3.	 In the Advanced Import dialog box, click Add.
4.	 Select MapInfo TAB [*.tab] from the Format drop-down list.
5.	 Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open. A coordinate system is detected.
6.	 Click OK to close the Add dialog box.

The selected file appears in row 1 of the file list. Now add another file in a different map file format.

7.	 Click Add to open the Add dialog box.
8.	 Select ESRI Shapefile [*.shp] from the Format drop-down list.
9.	 Click Browse, navigate to the Tutorial Data folder, select canada.shp, and click Open.
10.	 Click OK to close the Add dialog box.

The selected file appears in the second row of the list.

11.	 In the Destination MAP View frame, usa is selected by default in the New Based On drop-down list. This bases 
the page scaling on the usa.tab file.

12.	 Check the Auto scale option.
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This ensures all selected files are scaled to fit inside the page extents.

Note:	 Not checking the Auto scale option will base the page scaling on the file selected in the New based on 
drop-down list only. Therefore only this file is fitted to the current page extents, which may cause elements in 
other selected files to be placed outside of the page boundary.

13.	 Click OK to import the two files.

Notice that in the Adobe Illustrator Layers panel there are new layers called usa_area and canada_area. Also in 
the MAP Views panel there is a new MAP View called usa containing the imported files.

14.	 Close the document without saving.

1.8	 Import MAP files with different coordinate systems

1.	 Create a new Adobe Illustrator document in landscape orientation.
2.	 Click the Advanced Import button on the MAPublisher toolbar
3.	 In the Advanced Import dialog box, click Add.
4.	 Select MapInfo TAB [*.tab] from the Format drop-down list.
5.	 Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open.
6.	 Click OK to close the Add dialog box.
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The selected file appears in row 1 of the file list. The coordinate system of usa.tab displays NAD27. The 
coordinate system preview area lists various parameters of the file including the name of the coordinate system, 
page and map anchors, visual scale, and map angle.

7.	 Click the Add button to add another file.
8.	 Select ESRI Shapefile [*.shp] from the Format drop-down list.
9.	 Click Browse, navigate to the Tutorial Data folder, select worldwest.shp, and click Open.
10.	 Click OK to close the Add dialog box.

The worldwest.shp file appears in the second row of the file list and displays the Robinson coordinate system.
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11.	 In the Destination MAP View frame, select the New Based On option and choose worldwest from the drop-down list.

This bases the coordinate system and page scaling on the worldwest.shp file.

12.	 Click OK to import the two files into the Robinson coordinate system.

The map files are automatically sized to fit the page. Note that the Auto scale option was not required to be 
checked in the Advanced Import dialog box. The page scaling was based on the worldwest.shp which contained 
larger geographic extents than the usa.tab in all four compass directions.

In the Adobe Illustrator Layers panel, new layers called usa_area and worldwest_area are added. Also, in the 
MAP Views panel there is a new MAP View containing the imported files (the MAP View has the same name as 
the file selected for the MAP View destination).

13.	 Close the document without saving.
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1.9	 Import map files to match an existing MAP View

This tutorial will produce the same results as Tutorial 1.8 - Importing MAP files in multiple coordinate systems.

1.	 Create a new Adobe Illustrator document in portrait orientation.
2.	 Click the Simple Import button on the MAPublisher toolbar.
3.	 Select ESRI Shapefile [*.shp] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select worldwest.shp, and click Open.
5.	 Click OK to close the Simple Import dialog box.

In the Adobe Illustrator Layers panel there is a new layer called worldwest_area. Also in the MAP Views panel 
there is a new MAP View called worldwest (which is set in the Robinson coordinate system).

6.	 Click the Advanced Import button on the MAPublisher toolbar, and then click Add.
7.	 Select MapInfo TAB [*.tab] from the Format drop-down list.  
8.	 Click Browse, navigate to the Tutorial Data folder, select usa.tab, and click Open.

The selected file appears in Row 1 of the file list. The coordinate system of usa.tab displays NAD27.

9.	 In the Destination MAP View frame, select the Use existing option and choose worldwest from the drop-down list. 

View the coordinate system of this map file in the coordinate system preview area.
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10.	 Click OK to import the file based on the Robinson parameters of the worldwest_area layer.

The file is imported and reprojected to automatically align with the worldwest layer. This functionality allows a 
user to easily register multiple files in differing coordinate systems.

In the Adobe Illustrator Layers panel there are new layers called usa_area and worldwest_area. Also in the 
MAP Views panel there is a new MAP View called worldwest containing the imported files set in the Robinson 
coordinate system

11.	 Close the document without saving.
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1.10	 Assign a source coordinate system prior to import

1.	 Create a new Adobe Illustrator document in portrait orientation.
2.	 Click the Advanced Import button on the MAPublisher toolbar. In the Advanced Import dialog box, click Add.
3.	 Select ESRI ArcInfo Generate [*.gen] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select ukrail.gen, and click Open.
5.	 Click OK to close the Add dialog box.

The selected file appears in the first row of the file list.

6.	 In the Advanced Import dialog box, with the first row selected, click Edit.
7.	 In the Edit dialog box, click Specify and choose British National Grid located under Projected > Europe > United Kingdom.
8.	 Click OK and OK again to return to the Advanced Import dialog box.

Under Destination MAP View frame, view the coordinate system information in the area to the right.

9.	 Click OK to import the file in the British National Grid coordinate system.
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10.	 Close the document without saving.

1.11	 Transform a coordinate system on import

Read about the MAP View Editor in chapter 4 of the User Guide before completing the following tutorial.

1.	 Create a new Adobe Illustrator document in portrait orientation.
2.	 Click the Advanced Import button on the MAPublisher toolbar, and then click Add.
3.	 Select ESRI Shapefile [*.shp] from the Format drop-down list.
4.	 Click Browse, navigate to the Tutorial Data folder, select ukpoly.shp,and click Open.
5.	 Click OK to return to the Advanced Import dialog box.

The selected file appears in Row 1 of the file list. The coordinate system of ukpoly.shp is currently WGS 84.
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6.	 In the Destination MAP View frame, select the Create New option, and click the Editor button to open the Map 
View Editor dialog box.

7.	 Click Specify, navigate to the *Recent* category list under Coordinate Systems > Projected and choose British National 
Grid. Alternatively, navigate to Projected > Europe > United Kingdom to choose the same coordinate system.

8.	 Click OK to close the Specify Source Coordinate System dialog box.
9.	 Click OK to close the MAP View Editor and return to the Advanced Import dialog box.

Under Destination MAP View, view the coordinate system information in the area to the right.

10.	 Click OK to import the file in the British National Grid coordinate system.
11.	 Close the document without saving.
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2.1	 Create MAP View on import

1.	 Open usa48.ai from the Tutorial Data folder.
2.	 In the Adobe Illustrator menu, click Window > MAPublisher > MAP Views to open the MAP Views panel or click 

the MAP Views button on the MAPublisher toolbar. 
3.	 Use Simple Import to import usa.tab from the Tutorial Data folder.

Notice that a MAP View called usa 1 is automatically created. The 1 denotes that a MAP View already exists with 
that name, so it adds a suffix to differentiate it. Each Adobe Illustrator layer comprising the MAP View is depicted 
with an icon that represents the Feature type contained on each of the map layers.

4.	 Continue with the next tutorial.

2.2	 Import a MAP View from existing MAPublisher documents

Continue working with the previous tutorial.
1.	 Keep the usa48.ai document open, create a new Adobe Illustrator document and make it active.
2.	 Click the top right corner of the MAP Views panel to open the options menu and click Import MAP Objects.

A list of MAP Views are available from any opened document containing MAP Views. In this case, the MAP Views 
usa and usa 1 are available to import.

2  MAP Views and Georeferencing
See User Guide, Chapter 4
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3.	 Check the usa check box in the Import column and click OK.

The MAP View is imported into the new document along with all the MAP Layers within that MAP View. It 
maintains the original scale and position of the usa MAP view.

4.	 Close the active document without saving, but keep the usa48.ai document open.
5.	 Continue with the next tutorial.

2.3	 Duplicate and delete MAP Views

Continue working with the previous tutorial.
1.	 In the usa48.ai document, select the usa MAP View.
2.	 In the MAP Views panel option menu, click Duplicate "usa".

A new MAP View called Copy of usa is created. It doesn't contain any Adobe Illustrator layers. Since only empty 
MAP Views can be deleted, use the following steps to delete it.

3.	 Select the Copy of usa MAP View and click the Delete button. Alternatively, in the MAP Views panel option menu, 
click Delete "Copy of usa".

4.	 Select the usa 1 MAP View and open the MAP Views panel option menu.

Notice that the Delete option is disabled. This is because a MAP View that still contains one or more map layers 
cannot be deleted. Move or delete all layers from a MAP View first before deleting the MAP View itself.

5.	 In the Adobe Illustrator Layers panel, delete the usa_area 1 layer. Alternatively, select the usa_area 1 layer in the 
MAP Views panel and click the Delete button.

6.	 Select the usa 1 MAP View and click the Delete button.
7.	 Close the document without saving.
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2.4	 Transform coordinate systems by drag and drop

1.	 Create a new Adobe Illustrator document in landscape orientation.
2.	 Use Simple Import to import world.mif from the Tutorial Data folder.
3.	 Use Simple Import to import worldwest.shp from the Tutorial Data folder.

There are two MAP Views: one called world, in the WGS 84 coordinate system and contains the world_area layer; 
and the second called worldwest, in the Robinson coordinate system and contains the worldwest_area layer.

4.	 In the MAP Views panel click the worldwest_area layer and drag it to the world MAP View.

       

The worldwest_area layer is instantly transformed into the WGS 84 coordinate system and matches the page 
scaling of the world_area layer.

5.	 Drag worldwest_area back to the worldwest MAP View and it will transform the layer back to the Robinson 
coordinate system.

6.	 Keep the document open for the next tutorial.

2.5	 Drag layers into existing coordinate systems

Continue working with the previous tutorial.
1.	 Use the Toggle Visibility button in the Adobe Illustrator Layers panel to hide the world_area layer.
2.	 In the Adobe Illustrator Layers panel, create a new layer called Extras, and move it to the top of the layers hierarchy.
3.	 With the Extras layer selected, roughly trace over some features that exist on the worldwest_area layer using the 

Adobe Illustrator Pen tool and give it a red colored fill.



25MAPublisher 8 Tutorial
2  MAP Views and Georeferencing

The new features are polygons. Make sure that the elements are closed so that the start and end points of the 
lines are coincident.

4.	 In the MAP Views panel, click the Extras layer and drag it into the worldwest MAP View.
5.	 In the Undefined Layer dialog box, select Area from the Feature type drop-down list, and click OK.

The Extras layer is now stored in the same coordinate system as the worldwest MAP View.

6.	 Keep the document open for the next tutorial.

2.6	 Drag new layers into different coordinate systems

Continue working with the previous tutorial.
1.	 In the Adobe Illustrator layers panel, use the Toggle Visibility buttons to hide the worldwest_area layer, and to 

make the world_area layer visible. The Extras layer is already visible.
2.	 In the MAP Views panel click the Extras layer and drag it into the world MAP View.

The Extras layer is moved to the coordinate system of the world MAP View. It is immediately transformed from 
Robinson to WGS 84 coordinate system and aligns with the data in the world_area layer.

3.	 Keep the document open for the next tutorial.
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2.7	 Edit layer names using search and replace

Continue working with the previous tutorial.
1.	 In the MAP Views panel option menu, click Layer Name Search & Replace.

2.	 In the Find what box, type _area. In the Replace with box, type _layer. Click the Replace All button.

The text _area is replaced with _layer in the name of all applicable layers.

     

3.	 Close the document without saving.
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2.8	 Specify a source coordinate system after import

1.	 Create a new Adobe Illustrator document in portrait orientation
2.	 Use Simple Import to import ukrail.gen from the Tutorial Data folder (do not specify a coordinate system).
3.	 In the MAP Views panel, double-click the ukrail MAP View to open the MAP View editor. Close the warning dialog 

box that appears (it appears because no coordinate system was specified).
4.	 In the MAP View editor dialog box, click Specify to open the Specify Source Coordinate system dialog box.
5.	 Select British National Grid located under Projected > Europe > United Kingdom.

6.	 Click OK to close the MAP View editor dialog box.

The source coordinate system for the file is now British National Grid. The MAP View is assigned a coordinate 
system and can now be transformed.

7.	 Close the document without saving.

2.9	 Transform a coordinate system using the MAP View editor

1.	 Create a new Adobe Illustrator document in portrait orientation.
2.	 Import fsatoronto.mif from the Tutorial Data folder. 

The map file is in the WGS 84 coordinate system.

3.	 In the MAP Views panel, double-click the fsatoronto MAP View to open the MAP View editor.
4.	 Change the name of the MAP View to Postal Code Zones.
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5.	 Check the Perform Coordinate System Transformation check box to enable its frame options and click Specify.
6.	 In the Specify Destination Coordinate System dialog box, select NAD83 / UTM zone 17N located under 

Projected > UTM > NAD83 and click OK. 

The Preview Pane displays how the new coordinate system are fitted onto the page.

7.	 Click OK to close the MAP Views editor dialog box.

     
The MAP View is transformed from WGS 84 to NAD83 / UTM zone 17N. See Appendix A2 on Projections and 
Datums in the User Guide for more information.  

8.	 Keep the document open for the next tutorial.
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2.10	 Edit scale and position

1.	 In the MAP Views panel, double-click the Postal Code Zones MAP View to open the MAP View editor.
2.	 Click the check box next to Show Anchors to display page and map anchor information.
3.	 Change the map scale to 1: 35,000 by typing 35000 in the Scale box.
4.	 In the Page Alignment frame, there are nine squares in the alignment control graphic. Click the center square to 

reposition the data to the center of the page.

The Preview Pane shows the new data extents and the page anchor values have been automatically updated.

5.	 Click OK.

The Postal Code Zones MAP View is rescaled and repositioned in the center of the page.
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6.	 In the MAP Views panel, double-click the Postal Code Zones MAP View to open it again.
7.	 In the Angle box, type 343.00 to specify an angle of rotation, then click OK.

The data is now rotated. Georeferencing has not been affected.

8.	 Close the document without saving.

2.11	 Copy a coordinate system from one layer to another

1.	 Create a new Adobe Illustrator document in landscape orientation.
2.	 Import worldwest.shp from the Tutorial Data folder. 

The map file is in the Robinson coordinate system.

3.	 Select the Canada polygon shape and assign a fill color to it.

4.	 In the MAP Views panel, double-click the worldwest MAP View to open the MAP View Editor.
5.	 Change the map scale to 1: 250 million by typing 250000000 in the Scale box.
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6.	 Click the Show Anchors check box to display the map and page anchors (if the artboard is blocking the anchor 
numbers, click the zoom out button a few times). In the Page Alignment frame, click the top left square to 
reposition the data to the top left of the page.

The Preview Pane shows the new data extents and the Page Anchor values have been automatically updated.

7.	 Click OK.

The worldwest MAP View is rescaled and repositioned in the upper left corner of the page. This can be used as a 
small inset map used to reference Canada and to Western Hemisphere countries.

8.	 Import canada.shp from the Tutorial Data folder.

The map file is in the NAD27 coordinate system.

9.	 In the MAP Views panel, double-click the canada MAP View to open the MAP View Editor.
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10.	 Check the Perform Coordinate System Transformation check box to enable its frame options. Check the Same 
As check box and select the worldwest MAP View in the drop-down list. Notice how the destination is set to 
Robinson and the datum shift is NAD27-CANADA MEAN to WGS84.

11.	 In the Page Alignment frame, click the center square to reposition the data to the center of the page.

The Preview Pane shows the new data extents and the Page Alignment values are automatically edited.

12.	 Click OK.

The MAP View is transformed to match the coordinate system of the worldwest MAP View.

13.	 Close the document without saving.
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2.12	 Create a new MAP View

This tutorial provides a basic overview of assigning georeferencing information to existing Adobe Illustrator 
documents. Please see Georeferencing an Adobe Illustrator File in the MAPublisher 8 User Guide for more information.

1.	 In Adobe Illustrator, open toronto.ai from the Tutorial Data folder.

This is a regular Adobe Illustrator document digitized in WGS 84 (degrees). It contains two Adobe Illustrator 
layers that do not have any georeferencing or attribute information. They are located in the [Non-MAP layers] 
section of the MAP Views panel.

2.	 In the MAP Views panel option menu, choose New MAP View. Close the warning dialog box.
3.	 Rename the MAP View to Toronto.
4.	 Under the Source Coordinate System section, click Specify.
5.	 In the Specify Source Coordinate System dialog box, choose WGS 84 located in Geodetic > World and then click OK.
6.	 Type 26175.038531 in the Scale box.  The data is in degrees so the scale value is approximated using the common 

formula 1°= 111.353 meters. 

7.	 Make sure that the dialog box matches the one above and click OK.
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8.	 Make sure the Toronto MAP View is selected and choose Specify Anchors in the MAP Views panel option menu.

The Specify Anchors dialog box establishes the tie-in point between map anchors (real world coordinates) and 
page anchors (coordinates in page units).

9.	 Set the Map Anchors to the value of a tie-in location of Long: –79.411893 deg and Lat: 43.611883 deg. Leave the 
Page Anchors to the default value of X: 0.000000 pt and Y: 0.000000 pt.

The option is available to specify anchors using another coordinate system. Our anchor points are using WGS 84 
coordinate system so the Use MAP View's coordinate system option is selected.

Note:	 The map/page anchor relationship can be established at any known tie-in point (preferably within the 
extents of the dataset being georeferenced).

10.	 Make sure that the dialog box matches the one above and click OK to apply the changes.
11.	 In the MAP Views panel, click and drag the Postal Code Zones layer into the Toronto MAP View.
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12.	 In the Undefined Layer dialog box, choose Area in the Feature type drop-down list and click OK.

The Postal Code Zones area layer is moved to the specified coordinate system of the Toronto MAP View.

13.	 Click and drag the Roads layer into the Toronto MAP View.
14.	 In the Undefined Layer dialog box, choose Line in the Feature type drop-down list and click OK.

The Roads line layer is moved to the specified coordinate system of the Toronto MAP View.

Both Adobe Illustrator layers are now map layers, in the specified coordinate system of the Toronto MAP View.

15.	 Close the document without saving.
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2.13	 Export data to GIS formats

1.	 Create a new Adobe Illustrator document in portrait orientation.
2.	 Use Simple Import to import fsatoronto.mif and torontostreets.mif. Click OK to add the fsatoronto MAP View.
3.	 In the MAP Views panel, select the fsatoronto_area layer and in the MAP Views panel option menu, click Export 

“fsatoronto_area".
4.	 In the Export dialog box, choose ESRI Shapefile [*.shp] from the Format drop-down list, click Browse, navigate to a 

location to save the shapefile, and click OK. The Dataset box is populated with the directory path.

5.	 Click OK to export the file.

View the contents of the destination folder. The fsatoronto layer is exported as an ESRI Shapefile with all 
attributes and georeferencing intact. This ESRI Shapefile consists of four files: fsatoronto.shp, fsatoronto.shx, 
fsatoronto.dbf, and fsatoronto.prj. It is ready to be used in software supporting this format. Descriptions of these 
file extensions can be found in chapter 2 of the MAPublisher 8 User Guide. 

6.	 In the Adobe Illustrator Layers panel, select all objects on the torontostreets_line layer.
7.	 Click the MAP Attributes panel button on the MAPublisher toolbar. Resize the MAP Attributes panel to see all 

the attribute column headings and click the Edit Schema button.
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8.	 In the column list, select #Length and check the Visible check box. Select FromLeft to view its schema and uncheck 
the Visible check box and click OK.

The #Length attribute is visible now and the FromLeft attribute is hidden.

Before continuing, the other Integer type columns need to be hidden.

9.	 Right-click the ToLeft column and click Hide Column.

Note:	 Alternatively, click the Show/Hide Column button and choose an attribute to make visible or hidden.
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10.	 Hide the remaining columns: FromRight, ToRight and Type.

11.	 Ensure torontostreets_line is selected. In the MAP Views panel option menu, click Export “torontostreets_line".
12.	 In the Export dialog box, select MapInfo TAB [*.tab] from the Format drop-down list, click Settings, ensure the 

option for Export visible attributes only is checked, and click OK.

This ensures that only visible attributes are exported (#Length and Street columns in the attribute table).

13.	 Click Browse and navigate to a location to save the export and click OK.

14.	 Click OK to export the layer.

The torontostreets_line layer is exported to MapInfo TAB format with the specified attributes and georeferencing 
intact. It is ready to be used in software supporting this format. View the contents of the destination folder. 
Four new files were created: torontostreets.tab, torontostreets.dat, torontostreets.id, and torontostreets.map. 
Descriptions of these file extensions can be found in chapter 2 of the User Guide.

15.	 Close the document without saving.
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2.14	 Determine the coordinates of a specific location

1.	 Open usa48.ai from the Tutorial Data folder.
2.	 In the Adobe Illustrator Tools panel, click the MAPublisher Location Tool. 

Notice that the MAP Location panel appears.

3.	 Move the mouse cursor (it looks like a cross hair) to a location on the map to view its geographic coordinates.

The MAP Location panel shows the WX and WY values and are constantly updated as the mouse cursor is 
moved around the map document. This tool also allows for the copying of coordinates.

4.	 With the MAPublisher Location Tool, determine a location on the map to generate coordinates for. Hold down 
the Shift key and click this location. Holding the Shift key and clicking on a location copies the coordinates to 
the Clipboard.

5.	 Open a simple text editor and use the Paste function to paste the coordinate values.

Note:	 The MAPublisher Location Tool panel continues to track the coordinates of the current cursor location 
regardless of which tool is currently selected in the Adobe Illustrator Tools panel. However, to copy 
coordinates to the clipboard, the MAPublisher Location Tool must be used.

6.	 Close the document without saving.



40 MAPublisher 8 Tutorial 
3  MAP Attributes

3.1	 View, edit and zoom with MAP Attributes

1.	 Create a new Adobe Illustrator document.
2.	 Import world.mif from the Tutorial Data folder.
3.	 With all of the art selected on the world_area layer, open the MAP Attributes panel (choose Window > 

MAPublisher > MAP Attributes) or click the MAP Attributes button on the MAPublisher toolbar. 
4.	 To edit attribute values, double-click inside a cell and type a new value.

All attribute values and some property attributes can be edited. MAPublisher creates some attributes which 
have the hash symbol (#) as a prefix. These attributes are editable (but must be made visible first). However, 
#Area, #Perimeter, #VertexCount, and #Length are properties of the geometry and cannot be edited.

Keep in mind to enter values that correspond with a column's type (e.g. only enter numbers into a column of 
type Real or Integer). The edits are automatically maintained in the attribute table once entered.

5.	 The widths of the columns in the MAP Attributes panel may be changed by clicking on the column separator 
and dragging it left or right. Right-click and click Resize all to fit content.

6.	 Click the column heading to sort column in an ascending manner. Click the column heading again to sort it in a 
descending manner.

Zoom to a specific piece of art via the MAP Attributes panel. Select an attribute record and click on the Zoom to 
Feature icon  . MAPublisher zooms to the area of the file where the artwork is located and displays it within 
visible handles.

7.	 Keep the document open for the next tutorial.

3  MAP Attributes
See User Guide, Chapter 5
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3.2	 Add a new column to a MAP Attribute table

Continue working with the previous tutorial.
1.	 If necessary, open the MAP Attributes panel and select all objects on the world_area layer. The panel displays all 

of its attribute columns and values.

2.	 Click the Edit Schema button at the bottom of the MAP Attributes panel. 

The Edit Schema dialog box displays the columns associated with the MAP Attributes table on the currently 
selected layer.

3.	 Click Add to add a new attribute column.
4.	 In the Name box, rename Attribute1 to Head of State. 

Note:	 Notice that spaces are not accepted for column names. MAPublisher inserts an underscore ( _ ) if a space is 
typed into a column name. Also, notice that the Display Name box is populated with the same name. This can 
be changed to reflect a name with no spaces in it.

5.	 In the Display Name box, remove the spaces, so the name becomes Head of State.
6.	 In the Type drop-down list, choose String (this allows the column to contain alphanumeric values).
7.	 Set a width of 10 (this is the number of characters which can be displayed in each cell).

In certain instances, a default value for an attribute may be required. Setting a Default Value gives each record 
the same value. Do not enter a default value for this tutorial.

8.	 Click OK to close the dialog box.

The new column is created and can be given values in the MAP Attributes panel.

9.	 Leave the document open for the next tutorial.
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3.3	 Change an existing column's properties

Continue working with the previous tutorial.
1.	 If necessary, open the MAP Attributes panel and select all objects on the world_area layer.
2.	 Open the Edit Schema dialog box and select Capital in the attribute column list.
3.	 In the Display Name box, rename it to Capital City. Also, change the size to 30.

The column type may be changed after it is created (e.g. convert a type real column to a type integer column). 
For this tutorial, leave the type as String. Also, any new polygons added to the world_area layer will have a 
default value of None.

4.	 Leave the Visible check box enabled and the Read-only and Derive value from expression unchecked.

5.	 Click OK. 

The column is now renamed and width increased to accommodate longer names.

6.	 Leave the document open for the next tutorial.
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3.4	 Create a new column using expressions

Continue working with the previous tutorial.
1.	 If necessary, open the MAP Attributes panel and select all objects on the world_area layer.
2.	 Open the Edit Schema dialog box.
3.	 Click Add to create a new attribute column called Annual_Increase and set the Type to Integer.
4.	 Check the Derive value from expression check box and click the Expression Builder button next to the Edit 

Expression box.

Build expressions by making selections from the Objects list in combination with using the operators available 
at the top of the dialog box.

5.	 In the Expression Components section at the bottom of the dialog box, double-click the Population column 
in the Objects list, click the * symbol button, click the ( symbol button, double-click Pop_Grw_Rt column, click 
the / symbol button, then type 100. Finally, click the ) symbol button to close the expression builder. The final 
expression in the Edit Expression box is: Population*(Pop_Grw_Rt/100).

The expression is valid statement means that the expression is correct and can be performed.

6.	 Click OK to close the Attribute Expression Builder dialog box
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The expression box is populated with the expression that was just created.

7.	  Click OK again to close the Edit Schema dialog box.
The Annual_Increase attribute column is updated with values calculated from the expression. Notice that these 
calculated values are grayed out. They can only be edited by modifying the attribute expression.

8.	 Close the document without saving.

3.5	 Join tables

1.	 Create a new Adobe Illustrator document.
2.	 Import fsatoronto.mif from the Tutorial Data folder.

3.	 Open the MAP Attributes panel and click the Join Table button at the bottom of the panel. 
4.	 Make sure the Data Type is set to Files (ASCII, Excel, Sdts, Dbf)*, click Browse next to the Dataset Name box and 

select avginc.csv from the Tutorial Data folder.
5.	 Click the check box to enable First line contains column names and choose FSA from the Matching Column 

drop-down list.

Leave the default Character encoding as System. Since there is only one MAP Layer in the MAP View, the 
Destination Target Layer will default to fsatoronto_area.

* The Data Type drop-down list is not available on Mac.
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6.	 The Matching Column drop-down list shows attribute columns of the same type (String) from the target layer to 
base the join on. In this case, the matching column is FSA.

7.	 Make sure that the dialog box matches the one above and click OK.

8.	 Scroll to the right to view the joined attributes.

The imported table is joined with the attribute table of fsatoronto. The additional match column is appended 
with a "1" after the name (in this case, FSA1). This helps to differentiate the joined column and the original FSA 
column. All columns to the right of FSA1 contain the joined table records.

9.	 Close the document without saving.
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4.1	 Plot points in decimal degree and degrees-minutes-seconds formats

1.	 Open usa48.ai from the Tutorial Data folder.

This document contains the conterminous United States. The polygons are on the usa_area layer, in a MAP View 
named usa. The specified coordinate system is United States: Albers Equal Area, meter.

2.	 In the MAP Views panel, click the Add MAP Layer button. In the Add MAP Layer dialog box, rename Layer 1 to 
cities, set the Feature type to Point and click OK.

3.	 Open the Adobe Illustrator Symbols panel (click Window > Symbols).
4.	 In the Symbols panel option menu, click Open Symbol Library > Other Library and load MAP Symbols.ai from the 

\Helpful Styles & Symbols\Symbols folder (see page iii).
5.	 Choose some city symbols in the Map Symbols panel and drag them to the Adobe Illustrator Symbols panel.

     

6.	 In the MAP Views panel, select the cities layer.
7.	 Open the MAP Point Plotter panel (choose Window > MAPublisher > MAP Point Plotter) or click the MAP Point 

Plotter button on the MAPublisher toolbar. 
8.	 To change the plot symbol, click the symbol and select MAP Symbol 03. Leave the Scale set to 100%
9.	 Set the Input Coordinate System to Use: WGS 84. 
10.	 Ensure that Decimal Degrees (D+[.d*]) is chosen in the Format drop-down list.
11.	 To plot a point for Los Angeles, type -118.4183 in the Long box and type 34.1151 in the Lat box. Click the Plot 

button to plot the point on the map.

4  Plotting Points
See User Guide, Chapter 6
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A point is plotted at the location of Los Angeles (34.1151 degrees north, 118.4183 degrees west).

12.	 Choose Delimited Degrees Minutes Seconds (D+dMM'SS[.s*]") from the Format drop-down list. 
13.	 To plot a point for New York City, type 73d56'39.0"W in the Long box and 40d41'14.0"N in the Lat box.
14.	 Click the symbol text name to select a symbol style, change the Scale to 150% and click Plot.

A point is plotted at the location of New York City (40 degrees, 41 minutes, 14 seconds north and 73 degrees, 56 
minutes, 39 seconds west).

15.	 Finally, plot a point for Chicago. Type 87d41'18"W in the Long box and 41d50'21"N in the Lat box. Alternatively, 
change the Format back to Decimal Degrees (D+[.d*]) and type -87.6883 in the Long box and 41.8392 in the Lat box.

All the points are plotted on the map. Experiment with plotting your own points, using different symbols, 
coordinates, coordinate systems and data.

16.	 Keep the document open for the next tutorial.
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4.2	 Plot centroids

Continue working with the previous tutorial.
1.	 Choose Plot Centroids from the MAP Point Plotter panel option menu.

The MAP View and Source layer are already set in the Plot Centroids dialog box. The Destination is already set to 
be a new layer called centroid. This creates a new destination layer since no existing point layer is present.

2.	 Change the Style to MAP Symbol 02 and change its scale to 50%.
3.	 Leave the other options as default and click OK to close the dialog box.

Points are plotted for the centroid location for each state polygon.

4.	 Close the document without saving.
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5  Drawing with MAPublisher
See User Guide, Chapter 7

5.1	 Create shapes with specific map dimensions

1.	 Create a new Adobe Illustrator document.
2.	 Import fsatoronto.mif and import torontostreets.mif from the Tutorial Data folder.
3.	 Transform the coordinate system of the fsatoronto MAP View to NAD83 / UTM zone 17 (see Tutorial 2.9).
4.	 Zoom to an intersection of these streets. A recommended zoom level is 600%.

To construct an imaginary building at precise map dimensions
5.	 In the MAP Views panel, add a new MAP Layer called Buildings and specify it as an Area Feature type.
6.	 In the Adobe Illustrator Layers panel, select the Buildings layer and click the MAP Area Tool (box) button in the 

Adobe Illustrator Tools panel. 
7.	 Click once near the intersection of the two selected streets to open the Add Area dialog box.
8.	 Type 50 into the Width box, type 30 into the Height box, check the Center area on click check box, and click OK.

Since the fsatoronto MAP View is in UTM, the units are displayed in meters. These settings create a rectangle 
50 x 30 meters. The center of the polygon locates at the single-click point from the previous step.
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9.	 Move the building to the southeast corner of the intersection. Rotate it so that it is parallel to College St. using 
the Rotate Tool. Give the building a fill color.

Presume that this building is an established grocery store. In a recent survey it was found that on average, the 
majority of its customers lived within 500 meters of the store.

10.	 In the main Adobe Illustrator Tools panel, click the MAP Measurement Tool.  Click the center of the building 
rectangle and move the cursor outwards until the distance is about 500 meters.

The MAP Measurement Tool displays a distance of about 500 meters. This helps to approximate a distance of 
500 meters around the grocery store. To measure multiple straight sections, hold the Shift key and click.

11.	 In the main Adobe Illustrator Tools panel, click the MAP Area Tool (ellipse) button. 
12.	 Single-click in the center of the building to open the Add Area dialog box.
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13.	 Type 1000 for both the Width and Height, check the Center area on click check box, and click OK.

A 1000 meter diameter circle (500 meter radius) is placed around the grocery store and shows where the 
majority of customers live. Notice that the streets which fall inside this circle, whether entirely or in part, are 
selected. The circle can be selected and styled like other area and line elements.

14.	 Close the document without saving. 
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6  Cropping with MAPublisher
See User Guide, Chapter 7

6.1	 Crop MAPublisher data with MAP Vector Crop Tool

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreetsjoined.mif and fsatoronto.mif from the Tutorial Data folder.
3.	 With all data on both layers selected, open the MAP Attributes panel.

Examine the table structure and map attribute records. Deselect the data and close the MAP Attributes panel.

4.	 Click the Map Vector Crop Tool from the main Adobe Illustrator Tools panel. 

Notice the mouse cursor has changed to a cross hair.

5.	 With the MAP Vector Crop Tool active, click and drag a marquee window that encompasses the desired map 
area to be cropped. Release the mouse button to complete the crop.

Note:	 To achieve a perfectly square crop area, hold the Shift key while dragging the marquee window.
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The map area is cropped to the defined area.

Note:	 If the size and extent of the crop is undesired, click Edit > Undo and then Geocrop again.

6.	 Once again, select all data in both layers and open the MAP Attributes panel.

Notice that the attributes have been maintained, but there are fewer features because of the Geocrop.

7.	 Close the document without saving.
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7  Art and Line Functions
See User Guide, Chapter 8

7.1	 Buffer art using an entered value

1.	 Create a new Adobe Illustrator document.
2.	 Import burlroads.mif from the Tutorial Data folder and assign NAD83 / UTM zone 17N as the source coordinate system. 

Navigate to the location, Projected > UTM > NAD83 to find the coordinate definition (Tutorial 1).
3.	 Select a few lines to be buffered.

4.	 On the MAPublisher toolbar, click the Buffer Art button  or choose Object > MAPublisher > Buffer Art.
5.	 In the Buffer Art dialog box, click the Only buffer selected art check box. Under the Buffer Width section, choose 

the Static Value option, in the Units drop-down list choose Meter, and type 25 into the adjacent box. Under the 
Destination section, choose the New Layer option and type Line Buffers into the box.

A static value of 25 meters represents a buffer value of 12.5 meters on either side of the selected roads.

6.	 Click OK to apply the buffer art settings.
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The lines that were selected for buffering now have a buffer around them on a layer called Line Buffers.

Buffered lines can be styled like any other object. Try this to make them stand out from the roads.

Alternatively, a Graphic Style can be chosen in the Buffer Art dialog box so that a style is automatically applied 
to the newly created buffer.

7.	 Close the document without saving.
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7.2	 Flip lines

There are two methods in MAPublisher to ensure that text labels are oriented correctly when they are attached to 
paths. The first is to check the Reverse right to left paths (flip upside-down text) option in Label Features or the MAP 
Tagger Tool. Alternatively, permanently correct any digitizing irregularities by using the Flip Lines function.

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreetsjoined.mif from the Tutorial Data folder.
3.	 Select the two lines as indicated in the graphic below and add arrowheads to the lines by choosing Effect > 

Stylize > Add Arrowheads.

     

4.	 Accept the default arrowhead style and click OK.

Arrowheads are added to the selected road lines. 

5.	 On the MAPublisher toolbar, click the Flip Lines button. 

Notice how the selected lines now have their beginning and end points switched (as indicated by the 
arrowhead). The orientation of the lines are permanently corrected. Any labels placed along these lines are now 
oriented correctly (labels would be oriented below the lines if the lines were not flipped). 

6.	 Close the document without saving.
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7.3	 Join lines based on attribute value

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreets.mif from the Tutorial Data folder.

Select individual line segments to see that lines are not joined with other line segments, even though the line 
may be of the same street.

3.	 Select all objects on the torontostreets_line layer.

In the MAP Attributes panel, notice there are 1197 line segments in the torontostreets_line layer.

4.	 On the MAPublisher toolbar, click the Join Lines button. 
5.	 In the Join Lines dialog box, choose Street from the Join on Attribute drop-down list. This specifies that the 

streets are joined based on the Street name attribute.
6.	 In the Destination Layer box, rename it to Joined Streets. It will be the name of the new layer containing the joined lines.
7.	 Type 0.01 in the Proximity box and make sure the proximity unit is set to Degree. Proximity is the tolerance setting 

used in the join process.
8.	 Ensure the Close Segment Gaps check box is unchecked.

9.	 Make sure that the dialog box matches the one above and click OK.

A new layer called Joined Streets is created and contains 264 line segments (according to the MAP Attributes 
panel). The original dataset contained 1197 line segments. Select an individual line segment and notice that the 
line is joined with line segments that share the same street name (the attribute the join was based on).

10.	 Close the document without saving.
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7.4	 Simplify lines

1.	 Create a new Adobe Illustrator document.
2.	 Import the ukrail.gen file from the Tutorial Data folder and specify British National Grid as the coordinate system. It is 

located under Projected > Europe > United Kingdom.

3.	 Select all objects in the ukrail_line layer and click the Simplify Lines button on the MAPublisher toolbar .
4.	 In the Simplify Lines dialog box, type 2000 in the Proximity box and choose Meter in the Units drop-down list.
5.	 Click Preview to see a preview of the simplified data with the current settings. 

     

6.	 Click OK to start the simplification process.

     

The selected lines are now simplified based on a proximity value of two kilometers (2000 meters) and have been 
simplified from 17,186 vertices to 8,756 vertices or a vertex reduction of about 50%.

7.	 Close the document without saving.
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7.5	 Join points

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreetsjoined.mif and torontopoints.mif from the Tutorial Data folder. After import, ensure the 

torontopoints_point layer is positioned at the top of the layers hierarchy in the Adobe Illustrator Layers panel.
3.	 If necessary, deselect all layers and only select the points of the torontopoints_point layer and open the MAP 

Attributes panel.

The ID attribute column contains four unique values identifying points that compose: two subway lines (S1 and 
S2), the mainline rail track (R1), and a park boundary (P43). The LineNumber and AreaNumber columns contain 
rising numeric values indicating the number of each point in its sequence. Note that some points contain 
matching values.

4.	 Deselect all points and on the MAPublisher toolbar, click the Join Points button. 

Since only one point layer is present in the document and there are no points selected, the Source Layer 
defaults to the torontopoints_point layer in the Join Points dialog box.

5.	 In the Destination Layer box, type              (a new layer will be created with this name) and leave the Close paths 
check box unchecked.

6.	 In the Group By Column drop-down list, choose ID. This contains the unique attributes that will be used to join 
similar points together.

7.	 In the Sort By section, click LineNumber in the Available Columns list, and click the right arrow button to add it to 
the Sort Order list. Click AreaNumber and click the right arrow button again to add it to Sort Order.

Ensure that LineNumber is at the top of the Sort Order list box. Having LineNumber at the top of the Sort 
Order column makes it the primary sorting column when determining the order of points in the chain. The 
AreaNumber column is used as the secondary sorting column, if any points in the primary column contain 
matching values.
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8.	 Make sure the dialog box matches the one above and click OK.

All the points are joined based on the specified parameters. A line layer called Joined Points is created that 
contains four new lines. The lines represent two subway lines, the mainline rail track, and the perimeter of a small 
park. To see the Joined Points line more clearly, hide the other layers.
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9.	 Select the four lines of the Joined Points layer and open the MAP Attributes panel.

Notice that an attribute column named ID was created and contains the values specified in the Group By 
Column setting in the Join Points dialog box. Note that the small segment with the attribute P43 is the outline of 
a park area. However, this segment should be closed and should be deleted using the following steps.

10.	 In the Adobe Illustrator Layers panel, select the torontopoints_point layer and use the MAP Selections to select 
all the points with an ID equal to P43 (see Tutorial 10 on Making Selections).

11.	 With the points of P43 selected, click the Join Points button.

In the Join Points dialog box, the torontopoints_point layer and Selected Points option are chosen by default.

12.	 In the Destination Layer box, type Park Area. This time, check the Close Paths check box. Leave the Group By 
column as the default of ID.

13.	 Add AreaNumber and LineNumber to the Sort Order column list, and make sure LineNumber is at the top of the list.

14.	 Make sure your dialog matches the graphic above and click OK.
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The selected points are joined based on the specified parameters. A new Park Area layer is created that contains 
a polygon that represents the perimeter of a small park. The map can be styled to more clearly show the subway 
lines, rail line and park.

     

15.	 Close the document without saving.
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8.1	 Create an area stylesheet

1.	 Create a new Adobe Illustrator document.
2.	 Import world.mif from the Tutorial Data folder.
3.	 In the Adobe Illustrator menu, choose Window > Graphic Styles to open the Graphic Styles panel.
4.	 In the Graphic Styles panel option menu, choose Open Graphics Style Library > Other Library and load 

MAP_AreaStyles.ai from the \Helpful Styles & Symbols\Graphic Styles folder (see page iii).
5.	 Shift-select all the graphic styles in the MAP_AreaStyles panel and drag them into the Adobe Illustrator Graphic 

Styles panel.

      

6.	 Open the MAP Stylesheets panel (choose Window > MAPublisher > MAP Stylesheets) or click the MAP Stylesheets 
button on the MAPublisher toolbar.

The world_area layer does not belong to any stylesheet, so it is automatically placed into [No MAP Stylesheet].

7.	 In the MAP Stylesheets panel option menu, click New MAP Stylesheet.
8.	 In the New MAP Stylesheet dialog box, type Continents1 into the Name box, choose Area from the Feature type 

drop-down list, and click OK.

9.	 In the MAP Stylesheets panel, drag the world_area layer into the Continents1 stylesheet.

     

10.	 Double-click Continents1 stylesheet, or choose Edit "Continents1" from the MAP Stylesheets panel option menu.

8  Legends and Stylesheets
See User Guide, Chapter 9
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11.	 In the Edit "Continents1" dialog box, click Add to add a style rule.

12.	 Rename Rule 1 to Africa and choose a style from the Style drop-down list (these are the styles previously added).
13.	 At the bottom of the dialog box, set the Expression Mode to Simple. Click inside the Expression field of row 1 

to open the Simple Expression builder. On the left-hand drop-down list, set the attribute to Continent, select the 
equal sign for the operator, and select Africa from the right-hand drop-down list as the attribute value. 

14.	 Leave the Scale as 100% and click Apply to see the changes made to the map.

Note:	 If changes are made to a style, click white empty space in the dialog box before clicking the Apply button.

15.	 Repeat steps 11 to 15 for each of the subsequent continents. Note that the same style cannot be used more 
than once, as one style equals one legend entry.
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16.	 When all of the continents are assigned a style, click the Apply button to see the changes, or click OK to close 
the dialog box.

The styles specified have been applied to the map. The styles in the Graphic Styles panel are now linked to the 
attribute values specified by the style rules.

17.	 Save this document as MyWorld.ai in the Tutorial Data folder. It will be used again in Tutorial 8.4.

8.2	 Create a line stylesheet

1.	 Create a new Adobe Illustrator document.
2.	 Import fcstreets.mif from the Tutorial Data folder.
3.	 Open the Adobe Illustrator Graphic Styles panel.
4.	 Use the Adobe Illustrator Line Segment Tool to create the first graphic style by drawing a line on the page. 

Assign it a stroke weight of 2 pt, a stroke color of red, and a fill of none. Drag this line into the Graphic Styles 
panel. In the Graphic Styles panel, double-click the style to give it a new name (e.g. Style 1).

          

5.	 Repeat the previous step to generate three more styles: green, yellow, and blue. Be sure to give each style 
a unique name and delete the lines when the styles are completed (the styles will remain intact inside the 
Graphic Styles panel).
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6.	 Open the MAP Stylesheets panel and in the panel option menu, click New MAP Stylesheet.
7.	 In the New Map Stylesheet dialog box, type Road as the name, choose Line from the Feature type drop-down list, 

and click OK.

8.	 In the MAP Stylesheets panel, click and drag the fcstreets_line layer into the Road stylesheet.

     

9.	 Double-click the Road stylesheet and in the Edit "Road" dialog box, click the Add button.
10.	 In the first row, use the Style drop-down list to choose Style1 (red).
11.	 In the Expression column, build the expression Number = "A25".
12.	 Change the Scale to 200%.
13.	 Repeat this process for each of the subsequent road numbers; where A31 is styled green, A45 is styled yellow, 

and A41 is styled blue. For these three road types, leave each scale at 100%.

14.	 When all the rules are defined with a style and expression, click OK.
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The styles specified are applied to the map. The styles used in the Graphic Styles panel are now linked to the 
attribute values specified by the style rules. Notice that road A25 (red) has a 4 pt stroke weight. This is due to the 
scale being set to 200%.

15.	 Save this document as MyRoads.ai in the Tutorial Data folder. It will be used again in Tutorial 8.5.

8.3	 Create a point stylesheet

1.	 Open MyPoints.ai (saved at the end of Tutorial 1.6) in the Tutorial Data folder.
2.	 Open the  Adobe Illustrator Symbols panel (choose Window > Symbols), in the Symbols panel option menu, click 

Open Symbol Library > Other Library and load Map Symbols.ai from \Helpful Styles & Symbols\Symbols (see page iii).
3.	 Shift-select all the symbols in the MAP Symbols panel, and drag them into the Adobe Illustrator Symbols panel.

          

4.	 Open the MAP Stylesheets panel and in the panel option menu, click New MAP Stylesheet.
5.	 In the New Stylesheet dialog box, type Point Data as the name, choose Point in the Feature type drop-down list, 

and click OK.

6.	 In the MAP Stylesheets panel, drag the azdeci_point layer from [No MAP Stylesheet] into the Point Data stylesheet.
7.	 Double-click the Point Data stylesheet and in the Edit "Point Data" dialog box, click the Add button.
8.	 In the first row, use the Style drop-down list to choose MAP Symbol 34 (airplane symbol).
9.	 In the Expression column, build the expression: C3 = "airport" and change the Scale to 70%.
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10.	 Repeat this process for each of these points: church, hospital and park. Choose an appropriate symbols for each. 
When all the rules are defined with a style and expression, click OK.

The symbol styles specified are applied to the map. The styles used in the Symbols panel are now linked to the 
attribute values specified by the style rules.

11.	 Close the document without saving.

8.4	  Duplicate stylesheets

1.	 Open MyWorld.ai (saved at the end of Tutorial 8.1) from the Tutorial Data folder.
2.	 In the MAP Stylesheets panel, select the Continents1 stylesheet, open the panel option menu, and click 

Duplicate "Continents1".

3.	 In the MAP Stylesheets panel, double-click the Copy of Continents1 stylesheet.
4.	 In the Edit "Copy of Continents1" dialog box, rename the stylesheet to Continents2.
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5.	 Use the Style drop-down list for each style rule to change the colors used to represent the continents. When all 
continents have been assigned different styles, click OK.

There are now two stylesheets available to use that have rules specifically for the world_area layer. 

6.	 In the MAP Stylesheets panel, click and drag the world_area layer from the Continents1 stylesheet to the 
Continents2 stylesheet.

     

The new styles assigned in this stylesheets are applied to the map accordingly. Now drag the world_area layer 
back to Continents1 to restore the map to its previous style scheme. Having multiple stylesheets defined allows 
a user to easily create multiple color schemes for the same map.

7.	 Close the document without saving.
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8.5	 Edit styles to change attributes

1.	 Open MyRoads.ai (saved at the end of Tutorial 8.2) from the Tutorial Data folder.

2.	 In the Adobe Illustrator menu, click the MAP Selections button.  (see Tutorial 10).
3.	 In the MAP Selections panel option menu, click New Selection Filter.
4.	 In the Expression box, type Number = "A45" (case sensitive, include quotes), and click to OK close the dialog box.

This filter selects all lines on the fcstreets_line layer that have a number equal to A45. The yellow line at the lower 
right corner of the document is the only line that is select with this filter.

5.	 With the line selected, open the Adobe Illustrator Graphic Styles panel, and assign the blue line style (Style4).
6.	 Open the MAP Attributes panel, to display the line attributes of the currently selected objects.

     

Notice that by changing to the blue line style, the line attribute has also been updated. By simply changing the 
style currently used to represent another attribute in the Road stylesheet, it has changed the Number attribute 
of the selected line from A45 to A41.

7.	 Close the document without saving.
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8.6	 Create a MAP Stylesheet legend

1.	 Open MyWorld.ai (saved at the end of Tutorial 8.1) from the Tutorial Data folder.
2.	 In the Adobe Illustrator Layers panel, rename Layer 1 to Legend.
3.	 Open the MAP Views panel, drag the Legend layer into the world MAP View. In the Undefined Layer dialog box, 

set the Feature type to Legend, and click OK.

4.	 In the Type Character panel, set the font to Arial and its size to 10 pt.
5.	 In the MAP Stylesheets panel, select the Continents1 stylesheet, and in the panel option menu, click Create MAP 

Stylesheet Legend. In the Create MAP Stylesheet Legend dialog box, set the Style preview to 20.00 pt x 15.00 pt 
and uncheck the Rule expression check box. Leave the Space between rules setting as default and click OK.

      

A legend is created on the Legend layer and placed on the artboard. Reposition it as necessary. Experiment with 
the Style preview to create different sizes.

Stylesheet legends can be created from any stylesheet (area, line, point or text). A stylesheet legend can display 
the symbol for the type of stylesheet used, the stylesheet rule names, and the expression used to create the 
rule. MAP Stylesheets legends can easily be edited because it is considered an Adobe Illustrator nested object.
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9.1	 Generate labels for a line layer using Label Features

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreetsjoined.mif from the Tutorial Data folder. 
3.	 In the MAP Views panel, add a new MAP Layer called Street Names and set the Feature type to Text.

4.	 In the Type Character panel, set the font to Arial and its size to 8 pt. This will be the style for the labels.
5.	 Select several streets from torontostreetsjoined_line to be labeled.
6.	 On the MAPublisher toolbar, click the Label Features button. 
7.	 Only one Source Layer is listed (torontostreetsjoined_line). In the Column drop-down list, select Street. In the Text 

Layer drop-down list select Street Names.

The Source Layer list shows the line, area, point and/or text layers currently containing selected data. For each 
layer, the Column drop-down list is populated with the attribute structure of that layer. Label the data based on 
a column that holds the appropriate attribute values. 

8.	 In the Label Settings area, click the Line Labels button on the left to assign MAPublisher line label settings (it 
should be enabled by default, if not, click it).

In the Label Settings area, users can specify label preferences such as label position, alignment to lines 
of latitude, minimum font sizes, and horizontal scaling to best place labels within polygons and paths.  
MAPublisher places line labels intelligently, depending on the curvature and length of the line string.

9.	 Set the Label Position option to Descender. Leave all of the other options as their default.

Labels can be modified if they exceed the length of the line with the current default font size.

9  Labeling Functions
See User Guide, Chapter 10
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10.	 Check the Adjust label if larger than line check box to activate the label rules. The order for the rules can be changed 
by clicking on the rule and then pressing the Up or Down arrow button.

11.	 Check the Reduce font size check box to reduce the size of the font to a specified minimum size in points. The 
default minimum font size value is set to 5 pt.

12.	 Check the Reduce horizontal scaling to a minimum of check box and set the value to 50%. This allows text to be scaled 
down horizontally by the fraction specified to adjust the kerning of the text.

13.	 Check the Set all labels to the same minimum font size check box.

If any of the labels have been adjusted in size due to the activation of a line adjustment rule, all labels can be 
resized to the same size. In this case, it is set to reduce to a minimum of 5 pt.

14.	 Make sure your dialog box matches the graphics above and click OK to label your map.

15.	 Close the document without saving.
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9.2	 Generate labels for an area layer using the MAP Tagger Tool

1.	 Create a new Adobe Illustrator document.
2.	 Import fsatoronto.mif from the Tutorial Data folder.
3.	 In the Adobe Illustrator Layers panel, create a new layer called Zone Names.
4.	 In the MAP Views panel, click and drag Zone Names into the fsatoronto MAP View, and set the Feature type to Text.
5.	 In the Type Character panel, set the font to Arial and its size to 8 pt. This will be the style for the labels.
6.	 Double-click the MAP Tagger Tool    button in the Adobe Illustrator Tools panel to open the Label Settings 

dialog box.

Similar to the Label Features in the previous tutorial, the label settings must be chosen before MAPublisher is 
able to determine the attributes that will be labelled. The Source Layer list shows the line, area, point and/or text 
layers currently containing selected data.

7.	 In the Label Settings dialog box, choose FSA in the Column drop-down list. This attribute contains the name of 
every postal code zone in the selected MAP Layer. The destination layer, Zone Names, is chosen by default. Click 
OK to confirm these settings.

Notice that the mouse cursor is now the MAP Tagger Tool cursor. Using the MAP Tagger Tool, click on any area 
feature to label it. You can click multiple times on an area to label it more than once.

Note:	 To create leader lines, hold the Shift key and click and drag. Release when the leader line is the appropriate 
length. To reopen the Label Settings dialog box, double-click the MAP Tagger Tool button.

8.	 Close the document without saving.
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9.3	 Create knockouts for labels

1.	 Open Contours.ai from the Tutorial Data folder.

Three MAP layers are visible: contours_labels, contours_line and Background. The contour labels are positioned 
above the contour lines. Use the Create Knockouts feature to mask the contour line below the label.

2.	 In the MAPublisher toolbar, click the Create Knockouts button .

The Create Knockouts feature bases the masks on the input of contours_line and contour_labels. Accept the 
default settings shown above to see how the knockouts will look.

3.	 In the Create Knockouts dialog box, click OK.

The knockouts are created. However, the labels are too close to the contours. Adjust the masks by adding some 
buffer and change the transparency. There is no need to undo the previous step.

4.	 In the MAPublisher toolbar, click the Create Knockouts button.
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5.	 Set the Mask opacity to 80% and set the Side buffer to 5.00 pixels.

The Mask opacity adjusts the transparency of the contour lines so that they will be slightly visible (100% opacity 
means that it is completely invisible). The side buffer adds space to the left and right sides of the label so that it 
creates the effect that the contour lines are further away from the label. The reason there is no need to Undo the 
previous mask is because the Replace existing knockouts option is checked.

6.	 Click OK to close the Create Knockouts dialog box.

The knockouts are created with a 5 pixel buffer and 80% opacity. To further adjust the mask, change the settings 
in the Transparency panel.

7.	 Click the Window menu and click Transparency. Click the Mask (right-hand frame). In the Adobe Illustrator 
Layers panel, click the target to select all the art of <Opacity Mask>. In the Transparency panel, adjust the 
Opacity to 100%. The masks are now invisible again.

8.	 Close the document without saving.
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10  Making Selections
See User Guide, Chapter 11

10.1	 Create an Attribute Filter

1.	 Create a new Adobe Illustrator document
2.	 Import fcstreets.mif from the Tutorial Data folder. It is a line file depicting the major roads of Falls Church, Virginia.
3.	 Select fcstreets_line and click the MAP Selections button on the MAPublisher toolbar. 
4.	 Click the Create New MAP Selection button at the bottom of the panel.

5.	 In the Name box, type Route number. Leave the type as Attribute Filter.

6.	 Click the Expression Builder button  to open the Expression Builder dialog box. 
7.	 If necessary, click the arrow button  to expand the Expression Components section.
8.	 In the Objects list, under the heading fcstreets_line, double-click Number so that it is entered into the expression 

entry box above. Click the equals (=) button and type "A25" (including quotes).

Note:	 To view the unique values of a specific attribute column, click display unique values under the Description 
box. Click a value to enter it into the expression entry box. It recognizes the attribute as a string and places 
quotations around the value.
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9.	 Click OK to close the Edit Expression dialog box.

The expression is valid.

10.	 Click OK once more to apply the selection to the map data.

Lines corresponding to the selection parameters are selected and the MAP Selection is saved in the panel.

     

11.	 Deselect all artwork and leave the document open for the next tutorial.

10.2	 Create a Spatial Filter

Continue working with the previous tutorial.
1.	 In the MAP Selections panel, click the Create New MAP Selection button.
2.	 In the New MAP Selection dialog box, type Intersect Route A25 into the Name box. In the Type drop-down list, 

choose Spatial Filter.

This spatial filter will select any roads that intersect with Route A25. Use the attribute filter that was created in 
the previous tutorial.

3.	 In the Filter Using drop-down list, choose Existing MAP Selection. In the frame below, the attribute filter Route 
Number is already chosen (because it is the only one).

4.	 Ensure that the Spatial Relationship drop-down list is set to Intersect and contain.
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5.	 Uncheck the Do not select art on the same layer as the 'Filter Using' art option.

Since this spatial filter is selecting art on the one and only MAP layer, this option must be unchecked.

6.	 Make sure the dialog box matches the one above and click OK.

     

Roads that intersect Route A25 are selected and the MAP Selection is saved in the panel.

7.	 Deselect all artwork and leave the document open for the next tutorial.
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10.3	 Create an Art Selection filter

Continue working with the previous tutorial.
1.	 Select all artwork on the fcstreets_line layer.
2.	 In the MAP Selections panel, click the Create New MAP Selection button.
3.	 In the New MAP Selection dialog box, type All Routes into the Name box. In the Type drop-down list, choose Art 

Selection and click OK.

     

All selected roads are saved as a MAP Selection in the panel. Now use the MAP Selections panel controls to 
select subsets and add or remove selections altogether.

4.	 In the MAP Selections panel, select the Intersect Route A25 spatial filter and click the Remove from Current 
Selection button.

All the roads that were based on the spatial filter are removed from the current selection.

5.	 Select the Route Number attribute filter and click the Add to Current Selection button.

Route A25 is added to the current selection. Experiment with different combinations to vary selections.

6.	 Close the document without saving.
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11  Working with Images
See User Guide, Chapter 12

11.1	 Register an image with a reference file

1.	 Create a new Adobe Illustrator document.
2.	 Import southchinasea.shp from the Tutorial Data folder and make sure the southchinasea_area layer is selected in 

the Adobe Illustrator Layers panel.
3.	 In the Adobe Illustrator menu, click File > Place, navigate to the Tutorial Data folder, select the sample raster 

image file borneo.tif, and click Place.

The raster image is placed at a default position and scale in the center of the screen.

4.	 With the image selected, click the Register Image button on the MAPublisher toolbar. 
5.	 Click the Load File button and select borneo.tfw from the Tutorial Data folder.

A warning that the coordinates from the reference file will be used in the registration process appears. This is 
normal and is not indicative of an issue with the data. All boxes in the dialog box are updated to reflect the data 
contained in the reference info file. Click OK to close the warning.

6.	 Click OK to register the image.
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The image is registered to the selected layer.

7.	 Select the raster image, right-click it and choose Arrange > Send to Back from the context menu.

The raster image is positioned below the southchinasea_area art work.

Note:	 A new map view can be created by registering a image on a non-map layer. The new map view will have the 
same coordinate system of the registered image, the image will be scaled to fit the document size. For more 
information on this see MAPublisher User Guide, Chapter 12.

8.	 Leave the document open for the next tutorial.

11.2	 Register an image without a reference file 

Continue working with the previous tutorial.
1.	 Select and delete the existing registered Borneo image from the document.
2.	 In the Adobe Illustrator Layers panel, make sure the southchinasea_area layer is highlighted.
3.	 In the Adobe Illustrator menu, click File > Place, navigate to the Tutorial Data folder, select the sample raster 

image file, borneo.tif, and click Place.

The raster image is brought in at a default position and scale in the center of the screen.
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4.	 With the image selected, click the Register Image button on the MAPublisher toolbar. 

One of the four corners of the raster image is what MAPublisher will use as the raster anchor point (Upper Left 
Placement, Lower Left Placement, Upper Right Placement or Lower Right Placement).

5.	 Click the Upper Left Placement (top left corner of the blue diagram) and type the following values into the 
Upper Left Placement X and Y boxes: X=108.3375605,  Y=7.7816585.

6.	 Make sure that Constrain Proportions option is checked and type pixel size X equal to 0.012773.

7.	 Make sure the dialog box matches above and click OK.

The image is registered to the selected layer. This method is useful if no reference file is available. However, it 
is necessary to know the coordinates for one of the corners of the image as well as the pixel scale in order to 
register the image correctly.

8.	 Leave the document open for the next tutorial.
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11.3	 Export a placed image as a georeferenced raster file

Continue working with the previous tutorial.
1.	 To set the color mode, in the Adobe Illustrator menu, click File > Document Color Mode.

Select RGB Color or CMYK Color depending on the color mode required for the exported raster image. 

2.	 For this example, choose CMYK Color.
3.	 Select the registered Borneo image if it is not already selected. On the MAPublisher toolbar, click the Export 

Image button. 
4.	 In the Export Image dialog box, choose GeoTIFF in the Store Geography As drop-down list to set the 

georeferencing output format.

5.	 Click Save As and navigate to a location to save the export image.
6.	 Type a file name (e.g. MyBorneo.tif ) for the export image and click Save to complete the export process.

The image of Borneo is exported as a GeoTIFF file using the coordinate system of the South China Sea layer. 

7.	 Close the document without saving.
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12.1	 Create an index grid

1.	 Create a new Adobe Illustrator document.
2.	 Import world.mif from the Tutorial Data folder.
3.	 In the MAP Views panel, add a new MAP Layer called Grid and specify the Feature type as Legend.

To use a style for a grid, one should first be created before it can be applied. A default grid style is used if no 
styles are defined.

4.	 Use the Rectangle Tool to draw a small rectangle with no fill color, choose a blue stroke color, and set a 0.5 pt 
stroke width.

5.	 Select the rectangle and drag it to Graphic Styles panel and rename it My Grid. Delete the drawn blue rectangle.

      

6.	 In the Adobe Illustrator menu, click Window > Type > Character Styles to open the Character Styles panel.
7.	 In the Character Styles panel, click the Create New Style button. Double-click Character Style 1, choose Basic 

Character Formats, and choose an Arial font at 8 pt size. Change the Style Name to My Grid Font (see the Adobe 
Illustrator Users Guide to learn more about Character Styles) and click OK.

8.	 In the Adobe Illustrator Layers panel, select the Grid layer. In the Adobe Illustrator menu, click the Grids and 
Graticules button on the MAPublisher toolbar. 

9.	 In the Grids and Graticules dialog box, click the Index Grid button to show its options. Leave the Number of 
Columns/Rows as the default of 10 for each box.

12  Grids, Graticules and Indexes
See User Guide, Chapter 13
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10.	 Under Grid Style Options, select My Grid from the Style drop-down list to set the grid line style. To keep the 
border of the grid the same as the lines, select My Grid from the drop-down list next to Draw Border.

11.	 Under Coordinate Values along Grid/Graticule Border, select the My Grid Font character style from each of the X Axis 
style and Y Axis style drop-down lists.

12.	 In the Labeling diagram, click the letter/number of "A  B" and "1  2" to enable the labels for all sides 
of the grid.

Clicking the letter or number enables or disables the display of labels on the grid. Clicking the bidirectional 
arrow reverses the order of the labels. For this example, leave the bidirectional arrows as the default.

13.	 Make sure your settings match the ones above and click OK to create the index grid.

An index grid is placed on the map. Each cell carries an alphanumeric identifier. To edit an existing grid, choose 
Object > Edit Index Grid to change the configuration settings or type of grid.

14.	 Save the document as MyGrid.ai. It will be used in Tutorial 12.4 Creating an Index: Featured Based.
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12.2	 Create a graticule

1.	 Create a new Adobe Illustrator document.
2.	 Import world.mif from the Tutorial Data folder.
3.	 In the MAP Views panel, add a new MAP Layer called Graticule and specify the Feature type as Legend.
4.	 Draw a rectangle with no fill and a blue stroke of 1 pt, then click and drag the rectangle into the Graphic Styles 

panel and rename it My Grid. Delete the drawn blue rectangle after adding it to the panel.
5.	 In the Adobe Illustrator Layers panel, highlight the Graticule layer and click the Grids and Graticules button.
6.	 In the Grids and Graticules dialog box, click the Graticules button to show its options. Under Latitude, type 20 in 

the Interval box. Under Longitude, type 20 in the Interval box.

Graticules can be plotted to intersect at specific lines of latitude and longitude. Pass through values of zero 
will create a graticule that passes through the Prime Meridian and the Equator. This graticule will have lines at 
intervals of 20 degrees.

The Vertices slider controls the number of nodes to construct the graticule. Higher numbers should be used if 
graticules are curved or in anticipation of transforming them. For now, leave the default setting. 

The Don't Label option is used in situations where the projection is creating a curved graticule that may have a 
section in one of the corners that do not need to be labelled. For example, when there is no data in the graticule 
or when there is only a small portion of the graticule showing and it does not need to be labelled. For this 
tutorial these options are not needed.

7.	 Under Grid Style Options, set the style to My Grid in the drop-down list. To keep the border of the grid the same 
as the lines, select My Grid from the drop-down list next to Draw Border.

8.	 In the Labeling diagram, click the Lng and Lat options located on each grid line. When enabled, the Lng and Lat 
options display as a bold typeface. If needed, hover over each toggle to see its description.

9.	 Make sure the dialog box matches above and click OK to process the graticule.
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A graticule is placed over the map. To edit a graticule, select it and choose Object > Edit Graticules.

10.	 Close the file without saving

12.3	 Create a measured (UTM) grid

1.	 Create a new Adobe Illustrator document.
2.	 Import torontostreets.mif from the Tutorial Data folder and perform a coordinate system transformation to 

NAD83 / UTM zone 17N, located in Projected > UTM > NAD83 (see MAPublisher User Guide, Chapter 4 or Tutorial 2.9).
3.	 In the MAP Views panel, add a new MAP Layer called Grid and specify the Feature type as Legend.
4.	 Create a My Grid graphic style with a 1 pt width stroke. Also, create a My Grid Font character style using Arial font 

and an 8 pt size (Tutorial 12.1).
5.	 Select the Grid layer and click the Grid and Graticules button on the MAPublisher toolbar.
6.	 In the Grids and Graticules dialog box, click the Measured Grid button to show its options. Set the Cell Size to 

1000 (meters) for both the width and height. Leave the Positioning options as default.
7.	 Under Display Options, set the style to My Grid. To keep the border of the grid the same as the lines, select My 

Grid from the drop-down list next to Draw Border.
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8.	 At the bottom of the dialog box, check the Append units to labels check box to show the units in the map 
document. The unit drop-down list to the right shows the units (Meter).

9.	 In the Labeling diagram box, click the X and Y label option at the end of each grid line. When selected the X and 
Y labels turns bold.

10.	 Under Coordinate Values along Grid/Graticule Border, choose My Grid Font for both X Axis style and Y Axis style 
drop-down lists. Leave Place label off line by the default of 6 pt.

Notice that labels in the Labeling diagram are highlighted with a green box when the mouse hovers over the 
different labeling options.

11.	 Click Preview to see the grid and the settings that were chosen.

12.	 Click OK to confirm the settings of the Measured Grid.

A grid is placed on the map based on the specifications made. Each cell line has UTM map coordinate labels. 
To edit an existing measured grid, go to Object > Edit Measured Grid to change the configuration Settings. If the 
grid is moved, the grid labels will automatically adjust to new coordinates.

13.	 Close the document without saving.
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12.4	 Create a feature based index

1.	 Open MyGrid.ai (saved from Tutorial 12.1).
2.	 In the Map Views panel, add a new MAP Layer called Index Label and specify the Feature type as Text.

3.	 Apply country labels to several or all of the countries using Label Features or the MAP Tagger Tool (see Chapter 
9).

4.	 Select the grid in the map document and click the Make Index button on the MAPublisher toolbar. 
5.	 Choose the Make index based on label and matching feature position option. In the Label Layer drop-down list, 

choose Index Label. In the Feature layer drop-down list, choose world_area (the layer that was labeled). In the Label 
text matches attributes drop-down list, choose Country (the attribute column used to label the map).

To get some fine tuning on the index, there are several advanced options that could be applied.
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6.	 Click the Advanced button.
7.	 In the Advanced Options dialog box, choose Feature label from the Sort Index by drop-down list. Under Output 

Formats, choose the Single-line expanded option. To add an attribute to the index, select additional attribute 
columns in the list.

For this example, Capital was chosen. The grid cell locator and feature name in the index file is separated by a 
single tab. The index is sorted alphabetically by feature label.

8.	 Click OK to accept the advanced options and in the Make Index dialog box, click Save As to save the index. 
Browse to a location to save the index, name it MyIndex.txt, and click Save.

A text file is created based on the specifications entered in the Make Index dialog box.

9.	 The index may be inserted into the map document by creating an Adobe Illustrator box and using the Place 
command (File > Place).

10.	 Leave the document open for the next tutorial.
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12.5	 Create a text based index

Continue working with the previous tutorial.

1.	 Select the grid in the map document and click the Make Index button on the MAPublisher toolbar. 
2.	 Select the Make index based on label position option.

Indexing by label position generates an index containing only grid cells that contain a text label within it. 

Note:	 Text labels are indexed according to the text object's anchor.

3.	 Click the Advanced button. Choose Grid Cell from the Sort index by drop-down list. Under Specify Index 
Separator, to the right of Attribute, click the tab button. In the Edit Attribute-Grid Separator dialog box, type , 
into the Custom box and click OK.

The grid cell locator and feature label in the index file is separated by a single comma. The index is sorted 
alpha-numerically by grid cell label.

4.	 In the Make Index dialog box, click Save As to save the index. Browse to a location to save the index, name it 
MyGridIndex.txt, and click Save.

5.	 Close the document without saving.
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13  Scale Bars and North Arrows
See User Guide, Chapter 14

13.1	 Create a scale bar

1.	 Open usa48.ai from the Tutorial Data folder.
2.	 In the MAP Views panel, add a new MAP Layer called Scale Bar and specify the Feature type as Legend.
3.	 In the Adobe Illustrator Character panel, choose an Arial font and 8 pt font size.
4.	 On the MAPublisher toolbar, click the Scale Bar button. 
5.	 In the Scale Bar dialog box, use the left and right arrow buttons to view scale bar styles (for this tutorial, use the 

default one). Select Kilometer in the Units drop-down list. In the Interval box, type 250.

Depending on the scale bar chosen, select the Number of horizontal lines to use in the plotted scale bar. These 
settings create a scale bar that equates centimeters on the page to kilometers on the map.

6.	 In the Number of labeled intervals box, type 4. Set the Number of intervals to subdivide to 1 and the Number of sub 
intervals to 5.

These settings create a scale bar that represents a total distance of 1000 km, has four main intervals each 
representing 250 km and where the first interval is further divided into five smaller intervals.

7.	 In the Labeling Options section, select Show above from the Display scale value drop-down list. Check the 
Display units to right of last interval label check box. Check the Display page to map units ratio check box, 
choose Centimeters  from the Page units for captions drop-down list, and choose Show below from the Placement 
drop-down list.

Look at the preview to see how these settings affect the look of the scale bar.

8.	 Click OK to close the Scale Bar dialog box.
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The Scale Bar is placed on the page according to the defined Settings. If necessary, resize the scale bar using the 
bounding box. The scale automatically adjusts after it is resized.

9.	 Click the scale bar to select it. Click and drag the top anchor of the bounding box to resize the scale bar.

     

10.	 Leave the document open for the next tutorial.

Note:	 The scale bar can edited through the Adobe Illustrator menu Object > Edit Scale Bar. When the MAP view is 
rescaled, the scale bar dynamically updates. The scale bar can be expanded to be edited as regular Adobe 
Illustrator artwork (however, doing so breaks the link to the MAP View scale value). 

13.2	 Create a north arrow

Continue working with the previous tutorial.
1.	 In the MAP Views panel, add a new MAP Layer called North Arrow and specify the Feature type as Legend.
2.	 Make sure the North Arrow layer is active and use the Adobe Illustrator Type tool to type the letter N. 
3.	 Select the letter N and click the North Arrow button on the MAPublisher toolbar. 

     

The type is changed from regular text (above left) to a north arrow (above right) and is aligned in the north 
direction. North arrows can be created from any art object in Adobe Illustrator including symbols and 
characters. Note that the north arrow created is added to the Symbols panel*.

4.	 In the MAP Views panel, double click the usa MAP View.
5.	 In the MAP View editor, set an Angle of 45 degrees, click the Auto Scale button and the center page alignment.

* Sample north arrow designs are located in the \Helpful Styles & Symbols\Symbols folder (see page iii). 
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6.	 Click OK to accept the angle edits.

The north arrow is oriented according to the MAP View it is placed in. Any changes made to the coordinate 
system or angle of the MAP View will cause the north arrow to automatically orient itself towards North.

7.	 Close the document without saving.
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14  MAP Web Author 
See User Guide, Chapter 15

14.1	 Prepare the map for Web tags

1.	 In Adobe Illustrator, click File > Open, navigate to the \Tutorial Data\MAPWebAuthor_Tutorial folder and open the  
Flash_Canada.ai tutorial document.

Before creating any Flash map, it is recommended to appropriately set the document size in Adobe Illustrator. 
This will also determine the size of the Flash map. Use Document Setup or the Artboard Tool to set the 
document dimensions. For this tutorial, the document is already set at 500 pixel width x 500 pixel height.

2.	 In the Adobe Illustrator menu, click the MAP Web Author button on the MAPublisher toolbar. 
3.	 In the MAP Web Author panel option menu, choose Specify Source Media Folder.
4.	 Select the Relative Path option and leave the Source Media Folder field blank.

This dialog box sets the path to the ImageFiles folder (the folder containing the image data) for Web tagging. To 
indicate that the ImageFiles folder is in the same directory as Flash_Canada.ai, leave the path blank.

5.	 Click OK to close the Specify Source Media Folder dialog box.
6.	 Click a province on the map and open the MAP Attributes panel to become familiarized with the attribute 

structure and data.
7.	 Close the MAP Attributes panel and continue to the next tutorial
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14.2	 Create Web tag callouts

This tutorial creates Web tags callouts for every object in the Provinces layer. These Web tags are used to expose 
attribute information when map features are clicked.

1.	 In the Adobe Illustrator Layers panel, click the target button beside the Provinces layer name to select all art on 
the layer.

2.	 In the MAP Web Author panel, click the Edit button to open the Multiple Web Tag Dialog dialog box.

3.	 In the Multiple Web Tag Dialog dialog box, type %NAME% into the Callout Title box.
4.	 In the Callout Image frame, make sure the By Attribute option is selected and type %IMAGE% into the box above.

The %NAME% and %IMAGE% variables retrieve values from the Provinces attribute table. In the case of 
%IMAGE%, the attribute is the image path. The image path and dimensions are shown on the right-hand side of 
the frame. By default, the Callout Preview is enabled. This previews what the Web tag callout will look like when 
exported to Flash.

Note:	 The attribute names are case sensitive and should match exactly as they are in the MAP Attribute table.
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Now, add more information to the Web tag callout by entering some basic HTML code. View the Callout Preview 
to see how it changes as the code is typed.

5.	 In the main content entry box type the following:

<b>Province:</b> %NAME%<br>
<b>Population:</b> %Population%<br>
<b>Capital City:</b> %CapitalCity%<br><br>
Go to the <a href="%OfficialWeb%">government website</a>

6.	 Click the Auto Size check box.

Click the Previous and Next buttons to scroll through the Web tags for each province. The dialog box title bar 
shows the current and total number of Web tags being edited. The Callouts can be manually resized, however, 
the Auto Size feature ensures that content will fit properly inside each Web tag.

7.	 Click OK to save the web tags and to close the Multiple Web Tag Dialog dialog box.
8.	 The MAP Web Author panel displays that one web artwork is selected (out of 13).

9.	 Keep the document open and continue with the next tutorial.
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14.3	 Export Flash map

After creating the Web tags, the next step is to export the map to Flash so that it can be viewed in a Web browser 
and shared over the Internet.

1.	 In the MAP Web Author panel, click the Export button.

2.	 In the Web Export Dialog dialog box, click the Browse button next to the Export Location box. In the Export File 
dialog box, navigate to \Tutorial Data and create a new folder called canada. Save the file into the canada folder 
and use the default file name of index.html. Click Save.

The Export Location box populates with the new file path.
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3.	 In the Web Export Dialog Export Settings tab, locate the User Toggle column and check the check boxes for 
Major city names, Major cities and Provinces.

The User Toggle allows the layers of a map to be turned on and off in the map interface.

4.	 Under the Options column for the Major city names layer, double-click to setup layer options. In the Layer 
Export Options dialog box, choose Hide the layer when the map is initially loaded option and click OK.

The Options column now shows that the Major city names layer is hidden when the map is initially loaded. 
Experiment with the other Layer Export options to see what kind of affect it has on the final map. Refer to the 
MAPublisher 8 User Guide for more information.

5.	 Leave the other options in the Export Settings tab as the default and click the Viewer Style tab.
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6.	 In the Viewer Style list, scroll down to Click Highlight Line and double-click the color value to change it. Select 
a purple color (#aa00ff or RGB 170, 0, 255) and click OK. Double-click the Line Thickness value and change it 
to 2. Scroll down to Hover Highlight Line and change the color to blue (#00aaff or RGB 0,170,255) and the Line 
Thickness to 1.

The Viewer Styles are used to style Flash elements on the map. Do not confuse these with the MAP Stylesheets 
or Adobe Illustrator graphic styles. These are strictly to style elements such as the Web tag callout, the 
navigation buttons, overview map and search box. Changing the default Viewer Style settings creates a 
Cascading Style Sheet (CSS) that contains CSS code that manipulates the look of the Flash elements. For more 
information about this and MAP Web Author, see chapter 15 of the MAPublisher User Guide.

7.	 Leave the options in the Viewer Settings tab as the default and click Export.

After finishing export, the Web Export Log dialog box appears. It provides a summary of which layers were 
exported, the corresponding export file name, the number of vertices in each layer and the Flash file sizes. It 
also provides a link to the Export Folder that was specified earlier.
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8.	 Click the Export Folder link to open the folder. The index.html is located in the export folder. Double-click the 
index_data folder to view all of the map export files.

9.	 Return to the canada folder and double-click index.html to open the Flash map in a Web browser.

     

Navigate the map using the map zoom slider and zoom in and out buttons, the pan tools and using the mouse 
to pan around the map. When the mouse hovers over a province, it highlights to the color specified earlier. Click 
the province and the Web tag callout appears with information defined in the Multiple Web Tag Dialog. Notice 
that the Major city names are hidden. This option was set earlier. Use the layers list to toggle the visibility of the 
provinces, major cities and city names. The overview map in the bottom right corner can be used to navigate 
the entire map without having to zoom out.

The latest Flash Player is required. It can be downloaded from the Adobe Website at www.adobe.com. If you 
encounter a Flash permissions warning, please see the Avenza Systems forums at www.avenza.com/forum.

10.	 Close the document without saving.
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15  Geospatial PDF Export

15.1 Export to geospatial PDF

1.	 Open usa48.ai from the \Tutorial Data folder.
2.	 In the Adobe Illustrator menu, click File > Export or click the Export Geospatial PDF button on the MAPublisher 

toolbar. In the Export dialog box, choose MAP Geospatial PDF from the Save as type drop-down list. Navigate to the 
\Tutorial Data directory, specify the file name as tutorial15.pdf and click Save.

3.	 In the Geospatial PDF Export Settings dialog box, click usa_area to enable the Model Tree Preferences.
4.	 Click the check box beside Use attribute for item name. Make sure the sort order is set to Ascending and click the 

Use Natural String Comparison check box.

This setting will use the attributes of STATE_NAME, in an ascending sort order, in the Model Tree.
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5.	 Open the operating system file browser window and navigate to the \Tutorial Data folder.
6.	 Double-click to open tutorial15.pdf in Adobe Acrobat Reader (the latest version is required).

The latest Acrobat Reader supports geospatial PDF files and comes with tools to explore the map. The Analysis 
toolbar holds three tools specific to geospatial PDFs: Object Data Tool, Measuring Tool and Geospatial Location 
Tool. On the left hand side, there are two useful Navigation panels related to geospatial PDFs: Layers and Model 
Tree. There are also Acrobat Reader preferences to change display elements such as geographic units. 

7.	 Click the Layers button in the Navigation panel to expand it. If it is not present, right-click the Navigation panel 
and choose Layers.

Only the usa_area layer is present in this geospatial PDF. Click the eye button to toggle the layer's visibility.
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8.	 Click the Model Tree in the Navigation panel to expand it. Click the + symbol beside usa, then usa_area to 
expand them. Click on a state to view its relative location on the map. Alternatively, use the Object Data Tool 
and click features on the map.

The Model Tree shows the map features of all the layers in the document. At the bottom of the Model Tree is a 
window that displays attribute data. In this case, the state name for the feature selected is California.

9.	 In the Analysis toolbar, click the Geospatial Location Tool. A status window appears in the bottom-right corner 
that displays the longitude and latitude of the cursor position.
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10.	 In the Analysis toolbar, click the Measure Tool. Click the southeast corner of Portland and draw a measurement 
line to the southeast corner of Kansas. Use the Object Data Tool to find these states if you are unfamiliar with 
the geography.

When the Measurement Tool is enabled, a secondary measurement toolbar appears that contains Snap Types 
and Measurement Types. A status window in the bottom-right corner appears that displays information on the 
distance measured, azimuth, latitude and longitude of the cursor position. In this case, the straight line distance 
from Portland to Kansas is approximately 1,996,912 meters (or about 1,997 km).

11.	 In the Acrobat Reader menu, click Edit > Preferences. In the Categories list, click Measuring (Geo).

This panel is used to change geospatial measuring options. See the MAPublisher User Guide for detailed 
information on all of its options and settings.
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12.	 In the Display Value As drop-down list, choose Degrees, Minutes, Seconds.
13.	 In the Use Default Distance Unit drop-down list, choose Miles.

14.	 Click OK to accept these settings.
15.	 Using the Measure Tool, choose several points to measure.

Notice that the distance is displayed in miles (mi) and that the coordinates are displayed as Degrees, Minutes, 
Seconds. Return to the Measuring (Geo) preferences to experiment with the settings to see how they can help 
you explore geospatial PDF maps.
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16.1	 Import ESRI Personal or File Geodatabase

In this tutorial, you will be importing data to be used for a Northern Ontario rail map.

1.	 In Adobe Illustrator, click File > New ,and create a new landscape oriented document.
2.	 Using Simple Import or Advanced Import click, from the Format drop-down list choose ESRI File Geodatabase [*.gdb] 

or ESRI Personal Geodatabase [*.mdb].
3.	 Click Browse and in the Tutorial Data folder select NorthernOntario.gdb to open a File Geodatabase or 

NorthernOntario.mdb to open a Personal Geodatabase.
4.	 The Select Feature Classes dialog box appears. Click the populated_points, canada_rail, and canada feature 

classes to select them.

5.	 Click OK to close the Select Feature Classes dialog box and OK again to import the feature classes.

Notice on import that the imported point data covers all of North America. You will import the data again, 
instead this time specifying a spatial filter and using SQL (Special Query Langauage) to perform an attribute 
filter to limit the amount of imported data.

6.	 Click Edit > Undo to remove the imported data.
7.	 Use Simple or Advanced Import again to import the NorthernOntario geodatabase.

16  Import Spatial Databases
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Note:	 To only use a spatial filter, click the Spatial Filter button on the Select Feature Classes dialog box.  
To perform both a spatial filter and an SQL query simultaneously, choose SQL Query.

8.	 In the Select Feature Classes dialog box, choose SQL Query and click the Create SQL Select Query button.

9.	 In the Create SQL Select Query dialog box, enter the following query:

		  SELECT * FROM populated_points WHERE populated_points.STATEABB='CA-ON';
		  SELECT * FROM canada WHERE canada.NAME IN ('Ontario', 'Quebec', 'Manitoba');
		  SELECT * FROM canada_rail 

10.	 At the bottom of the dialog box, click the Specify Spatial Filter button.

Note:	 Note that the spatial filter has been defined by the extents of the data selected by the SQL query. Through 
the spatial filter, you will further refine the selection to an envelope just beyond Northern Ontario.
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11.	 Enter the following spatial envelope values:

Be sure the Intersects relationship option is chosen, as this will allow the import of data that can later be 
cropped if not needed. Click OK to confirm these values, OK again to confirm the SQL Query, OK to close the 
Select Feature Classes dialog box, and finally OK to import the features. 

The feature classes are successfully imported using the SQL query and spatial filter.

12.	 Close the document without saving.
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16.2	 Import ESRI ArcSDE Geodatabase

ESRI ArcSDE technology is a means to interface with and access spatial data from an RDBMS (Relational Database 
Management System). Data stored in an ArcSDE is accessed from a server, whether on an internal network, or 
externally through the Internet. The Utah GIS Portal (http://gis.utah.gov) is one such resource that serves GIS data 
free of charge. This tutorial requires the use of an Internet connection.

1.	 In Adobe Illustrator, click File > New ,and create a new landscape oriented document.
2.	 Using Simple or Advanced Import, choose ESRI ArcSDE Geodatabase from the format drop-down list.
3.	 Click Browse. In the Browse ArcSDE Geodatabase dialog box, select Connections and click the Create New 

button to enter the following parameters: 

					     Connection Name: UtahGISPortal
					     Server: gdb93.agrc.utah.gov
					     Service: 5151
					     Database Name: SGID93
					     User Name: agrc
					     Password: agrc
					     Transactional Version: sde.DEFAULT

4.	 Click OK to confirm the connection settings.
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The UtahGISPortal connection is saved to the list. A saved connection can be accessed again in the future.

5.	 In the Browse ArcSDE Geodatabase dialog box, make sure UtahGISPortal is selected and click OK.

Note:	 Depending on the Internet connection speed, it may take a few seconds to connect to the server.

6.	 In the Select Feature Classes dialog box, type Bioscience into the MAP Dataset box. Choose the feature at the top 
of the list SGID93.BIOSCIENCE.DominantVegetation and click OK.

Note:	 After clicking OK, it may awhile to retrieve the data from the ArcSDE server.
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7.	 In the Simple (or Advanced) Import dialog box, click OK again to finalize the import.

The DominantVegetation layer for Utah downloads and is imported into Adobe Illustrator successfully.

Note:	 The connection parameters to this ArcSDE database service may have changed since the time of printing. 
Updated parameters should be available on the Utah GIS Portal website located at http://gis.utah.gov.

8.	 Close the document without saving.
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16.3	 Import Basic ESRI ArcSDE Server 

Users who do not have an ArcGIS license can install the free ESRI desktop application called ArcReader (see the ESRI
Website for information - www.esri.com). File and Personal Geodatabases cannot be read and access to files with
Basic ESRI ArcSDE Server connections is limited compared to the ESRI ArcSDE Geodatabase connections.

1.	 In Adobe Illustrator, click File > New and create a new landscape oriented document.
2.	 Using Simple or Advanced Import, choose Basic ESRI ArcSDE Basic from the Format drop-down list.
3.	 Click Browse. In the Browse Basic ArcSDE Server dialog box, select Connections and click the Create New button 

to enter the following parameters:

					     Connection Name: UtahGISPortal_Basic
					     Server: gdb93.agrc.utah.gov
					     Service: 5151
					     Database Name: SGID93
					     Version: sde.DEFAULT
					     User Name: agrc
					     Password: agrc

4.	 Click OK to confirm the connection settings.
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The UtahGISPortal_Basic connection is saved to the list. A saved connection can be accessed again in the future.

5.	 In the Browse ArcSDE Geodatabase dialog box, make sure UtahGISPortal_Basic is selected and click OK.

Note:	 Depending on the Internet connection speed, it may take a few seconds to connect to the server.

6.	 In the Select Feature Classes dialog box, type Bioscience into the MAP Dataset box. Choose the feature at the top 
of the list SGID93.BIOSCIENCE.DominantVegetation and click OK.

Note:	 After clicking OK, it may awhile to retrieve the data from the ArcSDE server.
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7.	 In the Simple (or Advanced) Import dialog box, click OK again to finalize the import.

The DominantVegetation layer for Utah downloads and is imported into Adobe Illustrator successfully.

Note:	 The connection parameters to this ArcSDE database service may have changed since the time of printing. 
Updated parameters should be available on the Utah GIS Portal website located at http://gis.utah.gov.

8.	 Close the document without saving.

Congratulations! You have completed the MAPublisher Tutorial Guide. Please see the MAPublisher 8 User Guide 
for more detail and information on specific features and commands. Check the Avenza Systems web site and 
forums for updates and more information.
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